dpkg 1.16.0 and upwards nagging about version numbers

After upgrading to dpkg 1.16.0 the other day I got messages like

dpkg-deb: error: parsing file '/var/lib/dpkg/available' near line xxx package 'yyyyyy': error in Version string 'zzzzzzz': version number does not start with digit

every time I used apt-get or aptitude.

Wondering what's up I found message 135 in Debian bug #620566 and found my /var/lib/dpkg/available still containing references to cnews.

Remembering the good old days of using dselect (well, at some point I really liked it, times changed) I ran

dselect update

which got this file up-to-date and me rid of the above messages.